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The Dobby Function in JacqCAD MASTER®

An overview of the Dobby menu includes:
Dobby On turns the dobby function on with the current active window.
Design to create the Peg Plan.
Draw in and Pegplan to create the Design.

The Draw in can be entered by: clicking on each harness in the grid 
above, or by use of a color strip or from a design or by entering the 
information numerically.
To take a design from another window to a pegplan: select the area, 
go to the Edit menu, and choose copy.  Go to the Dobby window and 
choose Clipboard to Pegplan (Clipboard==>PgP) in the Dobby menu.

The Dobby settings dialog allows you to amend the default settings of the Dobby function.  It is 
also where you can enter the threading numerically.  Here you can enter nested numbers.  This is 
explained in detail on page 7 of this handout.

Each time you make a change and want to see the result in the other two coordinates, click on the 
upper right corner with appropriate coordinates selected.

A Dobby pattern consists of three design elements:
The Draw-in (threading)
The Pegplan (weave) and
The Design area (draw down).
A combination of any two of these three elements can produce the third.
Here are three ways in which you can use two of the elements to create the third:

1.Draft the Draw-in or DiD and the Pegplan or PgP and generate the Design or Dsn from 
them.  DiD & PgP== >Dsn

2.Generate a Draw-In or DiD (threading) and Pegplan or PgP from the Design or Dsn 
(draw down) area.  Dsn== >DiD&PgP

3.Threading with drawdown to produce the pegplan.  Dsn+DiD== >PgP

While working in the design area all editing functions are 
available.  You can copy and paste parts of the design to other 
areas of the design.  You can copy from window to window, as 
usual.



11/23/2004 Dobby Function:  2

JacqCAD MASTER®   Handouts

DRAFT

Working in the Design Area

A good starting point:
Create a small window, the width should relate to your repeat unit for the dobby loom.  The number 
of harnesses at the loom dictates this.
The window for this example is 8 x 8.

Go to Wel Grid (which stands for Weave Element) in the Weave menu,
Choose Line grid
(The grid is defined by the weave display prefs in the Weave menu.)

Go to the Weave menu,
Choose Dobby,
Choose turn on Dobby.
The Peg Plan and Draw in areas are now displayed at the side and top of the existing window, which 
is the Design area for the Dobby.

In the example below, the simplest approach has been taken.  Using the pencil tool and color #255, 
pixels in design area have been painted black.  This marks the harness for use in the Draw in and 
the Peg Plan.  (Please note it is possible to generate Designs that are impossible to weave as dobby 
patterns. JacqCAD MASTER will give an error when the pattern requires more harnesses than can 
exist n a dobby loom.)

To check the repeat, make repeats window in 
the Options menu has been used.  The example 
on the right shows the design repeated 2 x 2.

Adjustments to the original design area in the 
dobby window were made while Live Update 
was turned on in the Options menu.  This 
allowed the changes to be seen repeated in the 
repeats window.

When the design area and the repeats were satisfactory, the 
Draw in and Peg Plan were generated using the upper right 
button.

The Design, Draw in and Peg Plan can be saved as a single file using 
File menu, and choosing Save.  This can be a good record of the pattern.  
However, it is the Peg Plan alone that is punched as a dobby loom file.  
The step-by-step instructions for taking the Peg Plan to a loom file are 
detailed on the last page of this handout.
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Using the Weave Brush in the Dobby Function:

1. File: New, Width: 8, Height: 8

2. Dobby on, Grid on

3. Make your foreground color #255 and background color #0

4. Double click on paintbrush to open the Paint Brush dialog 
box.  Choose weave brush.  Choose ISO to create a weave using the International Standard 
Organization system.  (See Paintbrush handout for full explanation of this system.)  The 
example below shows an 8 harness filling satin a.k.a. 8 shaft sateen.  Create the desired 
weave, click on OK.  Choose Done.  Click on OK. 

 Now you have a weave that you can paint with in your dobby design area.

5.  You may find it useful to fill the entire area of the design with 
the brush pattern and use this as a ground structure.  One way to do 
this quickly is to Select All (Command A), Fill with Brush pattern 
(Command, Control U).  

Since this step is done as a fill rather than painting directly, the pattern 
is a floating object until it is set.  This means you can adjust the end 
and/or pick it starts on by holding down the shift key and clicking on 
the direction arrows on your keyboard.  This will roll the weave as 
though it is on a tube, within the selection. 

6. When you are happy with the alignment you can set the pattern as you would any floating 
object by clicking on the set tool in the toolbox or clicking on a non-selection tool to deselect 
it.  You cannot click outside the selection to deselect it because we used the select all, so there 
is no “outside.”

7. Using the pencil tool and #255 as the foreground color, add cuts to the weave.  Remember 
wherever color #255 exists, that warp end will be raised.  To subtract cuts from the weave, 
use color #0 as your foreground color.  Wherever color #0 is used the filling will be on the 
top, warp end down.

8.  Click on arrows out to generate Draw 
in and Pegplan from design.

9.  Save your work if you want.  You can 
proceed with the final steps of making 
the loom file as discussed in the last page 
of this handout.
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Working with flipping and pasting to further develop an existing pattern.

1. Edit: Select All, Edit: Copy, File: New.
In this example, the 
window is 28 wide 
even though the unit 
of repeat is 8 wide.  
Full units of repeat 
would cause problems 
when mirrored.  It is 
important to avoid 
a threading that has 
harness #1 followed by 
harness #1, or harness 
8 to be used two times 
in a row.

2. Dobby on, Grid on.
3. Paste unit at far left.  Set paste.  (The dobby works from left to right and from bottom to top.)
4. Use Command V to past again, adjust to desired position.

Use tab key to move 
paste one full unitʼs 
width to the right.  
Use arrow to move 
left one pixel to 
avoid repeating a 
harness two ties in the 
threading.  (Or the tab 
spacing can be set to 7 
by double clicking on 
the scroll-hand tool in 
the toolbox.)

5. Use the past control to flip the paste.  Set the paste.
6. Repeat Process until width 

is filled.
7. Check repeat with Make 

Repeats Window in the 
Options menu.

A 2 x 2 repeat is shown here.

When drawdown design is satisfactory, 
click on arrows to generate threading 
and pegplan.
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Creating the Draw in Using the Colorstrip Method.

As already shown, there are various methods for creating the 
Draw in.

When using a color strip to create the Draw in the Dobby 
function, each color is a number and each number is the harness 
number.  Unless working with a color strip, #255 is used to 
indicate a harness lift in the Peg Plan and a harness threaded in 
the Draw in.

To Work with the Color Strip Method:
Make a window 1 pixel tall than the paste from the clipboard, if you are pasting from the clipboard; 
justify the paste to the bottom. (This avoids pasting the clipboard over the highest harness.)

Across the top pick of the design area, use colors to represent the harness threading sequence.

So color 1 = Harness 1,
 Color 2 = Harness 2, etc.
Now go to the Weave menu,
Choose Dobby,
Choose Colorstrip == > DiD

To use a tiled brush as a Draw in, place a line 
across the top pick, make it a solid color.  Define 

your brush (see the Brush handout for help on this) and Bucket the pattern in using the Control key 
with the Bucket tool.

If you want to be able to adjust the start end, rotating the colorstrip sequence as though it exists on 
a tube, select the area and use Command, Control U to fill the brush pattern.  This is still a floating 
object so you can adjust the orientation easily.  Hold the Shift key while you click on the arrow key 
on your keyboard that corresponds to the direction you want to roll the color sequence in the tile 
brush pattern.

The color strip does not automatically repeat unless you use a pattern fill or paint with the tile brush.  
The Dobby works from the bottom up (from the first pick to the last) and from left to right.

A mouse click on the upper right corner arrows while holding down the 
Control key will cycle the upper right corner arrows through the different 
options:

When the dobby weave is complete, save it.

It will be saved in the same format you see 
when you save it.  In other words, when you reopen this file it will still be in 
the dobby format, showing the Draw in and Pegplan.
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Working Directly in the Design Area.

You can also create a Draw in by working directly in the grid with the pencil tool.
This can then be imported into the design area.

Do this if you want to continue to work the same sequence down below.
To take the Draw-in to the Design area:
Go to the Weave menu,
Choose Dobby,
Choose DiD to Colorstrip

In the example above a satin weave was applied on top of the 
colorstrip, creating binder points for the weave.  Color 8 was changed to 255 to become a cut color.

You can check the 
repeat by using 
Make Repeats 
Window in the 
Option menu.

A 2 x 2 repeat is 
shown here.
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To Enter the Draw In Numerically:

Go to the Weave menu, choose Dobby, choose Dobby settings, 
click on the button Draw In, beneath Set/Edit.

This gives a text box in which you can type the number 
sequence.  Be sure to have a space or a comma between each 
number 1,2 vs. 12, which will be read as twelve.  Nested 
numbers for Complex sequences are allowed here.  An in-depth explanation is provided below.  The 
numeric sequence automatically repeats to fill the width of the window, starting at the left edge.  The 
color strip does not automatically repeat unless you use a pattern fill or paint with the tile brush.

Nest Numbers:
(available in version 3.50b0 22nov99)

In the Image menu: “Text Seq. To Col.Strip” provides support for copying a “Text Sequence” to a 
horizontal or vertical Color Strip in the image.  The “Text Sequence” is a plain text file (created by 
any text editor, such as Simple Text, BBEdit or Plain Text, or a word processor such as Microsoft 
Word as long as the file is Saved As.. Text).

The sequence in the “Text Sequence” file can be any combination of the following 3 forms:
1. Color List: C1 C2 C3… 1 3 2 4
2. Color Run:  N*C1  6*2 = 2 2 2 2 2 2
3. Repeat:  M[ … ] 3{1 2]=1 2 1 2 1 2 

Examples:
1 3 4 * 2 3[4 5]3 1 == > 1 3 2 2 2 2 4 5 4 5 4 5 3 1 
2[ 1 2[3 4] 5] 6 == > 1 3 4 3 4 5 1 3 4 3 4 5 6

Notes on Nested Sequences:

Repeats can be nested up to a maximum of 16 deep.  Valid separators between numbers are Space, 
Tab, Comma or return.  This allows you to format your sequences as desired.

Valid symbols for Color runs are “*”, “x”, “X”, and “.” In other words 4*2, 4x2, 4X2 and 4.2 are 
equivalent.  Valid symbols fro Repeats are [ ] and ( ). In addition, you can include “comments” 
which will be ignored.  They are used for “notes to yourself” and take the form:
 {everything between curly brackets is ignored}
For example, the sequence “2[ 1 2 [3 4] 5] 6” could be entered in the following format:
2(    {two repeats of six each}
  1 2[
      3 4   {my inner repeat, makes 4 boxes}
        ]
      5
   )   {end of outer repeat}
6
or whatever arrangement made the most sense for you.
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Once the sequence file has been opened and checked, you will be shown a dialog in which you select 
the direction (Left to Right, Right to Left, Top to Bottom, or Bottom to Top), starting location (End, 
Pick) and the number of pixels to paint.

Punching the Pegplan as a Loom File.

This involves:
1. Converting the Pegplan to a PICT file.
2. Expanding the file for the addition of box motion.
3. Applying box motion information.
4. Punching the file using the appropriate cast out file.

I. Place the Peg Plan in its own window.
A. Go to the Weave menu
B. Go to Dobby
C. Choose Peg Plan to Clipboard (PgP== > Clipboard)

II. Open a new window.
A. Make the size of the window to coordinate with the size of the Peg Plan.
B. Paste the Peg Plan into the window.  Go to the Edit Menu: Paste

III. Expand this file in Simplified expansion.
A. Expand 1 x in the ends and 1 x in the picks.

IV. The Box motion (filling Selectors) is applied in the same way as any other 
expanded file.

A. Go to Assign Boxes and Regulators in the Weave menu, choose:
1. By text in Assign Boxes and regulators or
2. By Color Strip in colorstrip to Box Assignments.

V. Punch with the appropriate cast out.  
A. The cast out used to punch this pattern will have to coordinate with the 

loom settings.  A typical example is 1-16 used for threading, 17-24 used for 
selectors but this will vary according to loom set up and manufacturer.

B. Go to Weave Menu, choose Punch As ..  Staubli, Socos or Dornier Dobby.
 


